Ultrex problems

Nitro & Tracker Boat Owners Forum

Help Support Nitro & Tracker Boat Owners Forum:

Idriller

NTO Supporter
NTO Supporter
Joined
Aug 19, 2020
Messages
26
Reaction score
15
Location
Mississippi
Started having ultrex issues the other weekend. While fishing a tournament the foot control became stiff and you couldn’t steer. Would work fine using the ipilot remote. Then you could try it again after using that ipilot remote for a while and it would work fine. Problem seems to come and go. I called minkota and they told me it’s problem a sensor or the board in the foot pedal. Really kinda disappointed. Just wondering if other people are having issues also. Lots of posts online about this.
 

Larry Williams

NTO Supporter
NTO Supporter
Joined
Sep 22, 2017
Messages
398
Reaction score
151
Location
Baton Rouge, LA
Idriller, Please let us know what the problem is exacty and how it gets resolved. I haven't had mine but since January- all good so far. Thanks for sharing- even though it's bad news. Hope you get it resolved quickly.
 

Allen Dronsfield

Well-Known Member
Joined
Jul 6, 2019
Messages
47
Reaction score
26
Location
Central, Fl.
I have a 2019 Ulrex, I had a problem with the coiled wiring would catch the adjustment knob for the height of the motor shaft and it would pull it out of the holed seat for the coiled wire, this would immediately kill the trolling motor and the spot-lock. Got that problem solved the dealer wired my trolling motor backwards and I had serious electrolysis issue with white crystallized powder around the prop nut, the gaps in the bottom end and the 4 bolts holding my lower end of the mercury and heat discoloration on the stainless prop. The shaft and lower end of ultrex has been replaced along with all other components messed up. Mechanically it has been very reliable other than these issues. I have a Mega 360 ordered and am waiting on it to arrive.
 

Idriller

NTO Supporter
NTO Supporter
Joined
Aug 19, 2020
Messages
26
Reaction score
15
Location
Mississippi
Well got my boat back today after 7 weeks~. In a nutshell BPS just replaced the entire trolling motor since it was under warranty. Haven’t had a chance to try it yet but feel confident it’s been solved.
 

Larry Williams

NTO Supporter
NTO Supporter
Joined
Sep 22, 2017
Messages
398
Reaction score
151
Location
Baton Rouge, LA
Well got my boat back today after 7 weeks~. In a nutshell BPS just replaced the entire trolling motor since it was under warranty. Haven’t had a chance to try it yet but feel confident it’s been solved.
Thanks for sharing an update...
 

Duane Mauzy

Well-Known Member
Joined
Jan 12, 2012
Messages
78
Reaction score
11
Location
Missouri
I had an issue after my first use. It rained all day, and a couple days later I used the TM and it started doing stupid things while it was running, the TM would anchor, then turn, then stop, then nothing. I took the motor in and the head was full of water. Replaced the head and no issues now.
 

Larry Williams

NTO Supporter
NTO Supporter
Joined
Sep 22, 2017
Messages
398
Reaction score
151
Location
Baton Rouge, LA
I had an issue after my first use. It rained all day, and a couple days later I used the TM and it started doing stupid things while it was running, the TM would anchor, then turn, then stop, then nothing. I took the motor in and the head was full of water. Replaced the head and no issues now.
That's interesting - I think I recall that there is no real "seal" arong the seam on the head unit cover to keep rainout in the stowed position...
 

Latest posts

Top