2021 Tracker Targa V19 Combo Tournament Edition

Nitro & Tracker Boat Owners Forum

Help Support Nitro & Tracker Boat Owners Forum:

Targa V19

Member
Joined
Mar 28, 2021
Messages
8
Reaction score
1
Location
Indiana
Purchased this boat new this spring. It is a fantastic boat to fish out of. The new electronics and trolling motor functions are just so cool to use. This is my fourth boat and it is like trading in your flip phone for the newest iPhone. That said, the boat has a lot of little build quality issues that are driving me crazy! Things missing that were supposed to be part of the package, parts installed incorrectly, loose and extra hardware showing up on my deck and in my bilge. First time out the trim gauge does not work and my transducer mount is loose. I am a retired mechanical engineering technician that worked for the Navy as a civilian and can and will fix minor issues. Taking it to the dealer in the middle of prime boating and fishing season is not going to make me feel better. I expect to be able to use a 50k purchase, not have it unavailable to me for repairs. The factory installed Humminbird transducer mount will not stay locked down above 35 to 40 mph. Why put this mount on a 55mph boat (200hp)? Getting ready to go outside to refasten the fuse block mount in place. Blew the fuse for the rear livewell and when looking for the problem found the fuse block hanging by one rivet attached to a piece of sheet metal and moving all over the place. The mounting block has four holes and only two were used to attach it at the factory. Just a small portion of the things I have found and already worked on myself. Sorry to be so long and venting so much, but this is very frustrating to a new boat owner. Happy Boating!
 

Larry Williams

NTO Supporter
NTO Supporter
Joined
Sep 22, 2017
Messages
398
Reaction score
151
Location
Baton Rouge, LA
Purchased this boat new this spring. It is a fantastic boat to fish out of. The new electronics and trolling motor functions are just so cool to use. This is my fourth boat and it is like trading in your flip phone for the newest iPhone. That said, the boat has a lot of little build quality issues that are driving me crazy! Things missing that were supposed to be part of the package, parts installed incorrectly, loose and extra hardware showing up on my deck and in my bilge. First time out the trim gauge does not work and my transducer mount is loose. I am a retired mechanical engineering technician that worked for the Navy as a civilian and can and will fix minor issues. Taking it to the dealer in the middle of prime boating and fishing season is not going to make me feel better. I expect to be able to use a 50k purchase, not have it unavailable to me for repairs. The factory installed Humminbird transducer mount will not stay locked down above 35 to 40 mph. Why put this mount on a 55mph boat (200hp)? Getting ready to go outside to refasten the fuse block mount in place. Blew the fuse for the rear livewell and when looking for the problem found the fuse block hanging by one rivet attached to a piece of sheet metal and moving all over the place. The mounting block has four holes and only two were used to attach it at the factory. Just a small portion of the things I have found and already worked on myself. Sorry to be so long and venting so much, but this is very frustrating to a new boat owner. Happy Boating!
It does seem more and more that pride in workmanship is going away... I hope things are ok beyond this stuff for you!
 

Targa V19

Member
Joined
Mar 28, 2021
Messages
8
Reaction score
1
Location
Indiana
Thanks for the good vibes. Ended up that the rivet was actually a self drilling screw going into very thin sheet metal, couldn’t have been more than a thread or two actually holding the fuse block mount in place. Drilled through the sheet metal and with a little help from the wife through bolted the top two holes into what turned out to be the back of the forward storage compartment. Good and secure now. Hopefully I can get out now and go catch some fish if the weather cooperates.
 

Sie805

Member
Joined
Sep 21, 2020
Messages
18
Reaction score
5
Location
Northern CA
I bought the same boat from Bass Pro last year. Ordered it in April and picked it up in June. They still owe me a full enclosure and the ski pylon. I had a few issues with things working loose but not too many. Good luck.
 

Targa V19

Member
Joined
Mar 28, 2021
Messages
8
Reaction score
1
Location
Indiana
I bought the same boat from Bass Pro last year. Ordered it in April and picked it up in June. They still owe me a full enclosure and the ski pylon. I had a few issues with things working loose but not too many. Good luck.
You have been waiting a year for something you paid for? You sir have the patience of a saint. How did your transducer mount work for you?
 

DONAOL

Active Member
Joined
Mar 25, 2021
Messages
39
Reaction score
3
Location
Finger Lakes
Purchased this boat new this spring. It is a fantastic boat to fish out of. The new electronics and trolling motor functions are just so cool to use. This is my fourth boat and it is like trading in your flip phone for the newest iPhone. That said, the boat has a lot of little build quality issues that are driving me crazy! Things missing that were supposed to be part of the package, parts installed incorrectly, loose and extra hardware showing up on my deck and in my bilge. First time out the trim gauge does not work and my transducer mount is loose. I am a retired mechanical engineering technician that worked for the Navy as a civilian and can and will fix minor issues. Taking it to the dealer in the middle of prime boating and fishing season is not going to make me feel better. I expect to be able to use a 50k purchase, not have it unavailable to me for repairs. The factory installed Humminbird transducer mount will not stay locked down above 35 to 40 mph. Why put this mount on a 55mph boat (200hp)? Getting ready to go outside to refasten the fuse block mount in place. Blew the fuse for the rear livewell and when looking for the problem found the fuse block hanging by one rivet attached to a piece of sheet metal and moving all over the place. The mounting block has four holes and only two were used to attach it at the factory. Just a small portion of the things I have found and already worked on myself. Sorry to be so long and venting so much, but this is very frustrating to a new boat owner. Happy Boating!
Seeing same issues on my 2021 Nitro Z19 Sport. Hole in dash, marks on dash, scrapes on bimini frame, radio loose, metal and plastic pieces and filings in bilge pump area. taking on water. Boat storage area full of left over materials. Only the water leakage fixed, lost use of boat for seven days. Sent e-mails to Nitro with pictures of problems. Paid for a brand new boat got a damaged boat. Asked for bimini frame replacement and dash replacement haven't heard from Nitro in almost two weeks. Very disappointed in workmanship. This boat could not have been inspected before leaving the factory. WARNING
: Slowly go over every inch of your new boat before you leave dealership.. Service department blames factory workers for poor workmanship.
 

Sie805

Member
Joined
Sep 21, 2020
Messages
18
Reaction score
5
Location
Northern CA
You have been waiting a year for something you paid for? You sir have the patience of a saint. How did your transducer mount work for you?
Affirm! Over a year. I need to start charging them interest on my money. I have the same problem with my transducer. It pops up whenever I come up to speed. I want to replace it with a metal one that's better quality but I just haven't got around to doing it yet. If you find a good mount, please let me know.
 

Targa V19

Member
Joined
Mar 28, 2021
Messages
8
Reaction score
1
Location
Indiana
Affirm! Over a year. I need to start charging them interest on my money. I have the same problem with my transducer. It pops up whenever I come up to speed. I want to replace it with a metal one that's better quality but I just haven't got around to doing it yet. If you find a good mount, please let me know.
Humminbird has a replacement metal mount but it would be solid. Same as putting the screw thru your plastic mount, you lose the safety of the pop out if you hit something. I am not willing to do that yet because of warranty. If my dealer wants to do it or Tracker approves it will shall see. Also not sure it will mount in the same spot as my factory mount. I am going to request that they install one of the sacrificial plastic blocks so any new holes are not thru my hull. Mounts are cheap but transducers are not. Going out to pop rivet the brackets on my Bimini, who thought that set screws in plastic was a good idea. Then I will try and figure out why my ski tow pole will not screw into its socket. I am pulling all my hair out with this constant crap!
 

Finman55

Member
Joined
Mar 23, 2015
Messages
7
Reaction score
1
Location
Oklahoma
I purchased new in 2015 a ProGuide V175 Combo. The boat leaked from the front live well day one, took three months & multiple trips to get that fixed. Just met a guy at Lake O Pines last week who bought the 2021 model like mine. Guess what it leaked from the live well. You can’t get caught in a heavy rain with these boats or leave them outside without a cover, because water gets in the storage lockers and can’t dry out. I didn’t know it at the time but before they got the leak repaired water had gotten into the foam underneath the floor & soaked it up like a sponge. It added so much extra weight to the boat that it was effecting the boat planning. I had to remove the pedestal seat mounts and leave it in the hot summer sun to finally get it dried out. My favorite quote was from the head warranty guy at the Tracker factory, when I called about the leak. He said “your not going to like what I’m going to tell you but all new boats leak.”
I told him “we’ll I must have missed that Part in your brochure, what page was that mentioned on”. If I had it to do over again I pay tbe extra 10k and buy the same design from Lund Boats.
 

Capt. Scully

Active Member
Joined
Apr 26, 2021
Messages
28
Reaction score
2
Location
Kearney, mo.
Purchased this boat new this spring. It is a fantastic boat to fish out of. The new electronics and trolling motor functions are just so cool to use. This is my fourth boat and it is like trading in your flip phone for the newest iPhone. That said, the boat has a lot of little build quality issues that are driving me crazy! Things missing that were supposed to be part of the package, parts installed incorrectly, loose and extra hardware showing up on my deck and in my bilge. First time out the trim gauge does not work and my transducer mount is loose. I am a retired mechanical engineering technician that worked for the Navy as a civilian and can and will fix minor issues. Taking it to the dealer in the middle of prime boating and fishing season is not going to make me feel better. I expect to be able to use a 50k purchase, not have it unavailable to me for repairs. The factory installed Humminbird transducer mount will not stay locked down above 35 to 40 mph. Why put this mount on a 55mph boat (200hp)? Getting ready to go outside to refasten the fuse block mount in place. Blew the fuse for the rear livewell and when looking for the problem found the fuse block hanging by one rivet attached to a piece of sheet metal and moving all over the place. The mounting block has four holes and only two were used to attach it at the factory. Just a small portion of the things I have found and already worked on myself. Sorry to be so long and venting so much, but this is very frustrating to a new boat owner. Happy Boating!
Targa, first, thank you for your service to our country, second my front fish well was leaking and filling the bilge. I am new to the world of bass boats and kind of stupid when it comes to some things, but some where in the back of my mind, a red flag popped up. I can't find the leak and don't feel like running the bilge pump all day, so I just don't use the front well.Problem Fixed ....or maybe
 

cceguy

Well-Known Member
Joined
Sep 21, 2020
Messages
55
Reaction score
7
Location
Indianapolis, IN
My livewell was split top to bottom, fore-and-aft, along the ribs that held the Plexiglas divider. Used marine epoxy on the outside, and Flex Seal Liquid Rubber on the inside. A year later, still doesn't leak.
 

Targa V19

Member
Joined
Mar 28, 2021
Messages
8
Reaction score
1
Location
Indiana
Affirm! Over a year. I need to start charging them interest on my money. I have the same problem with my transducer. It pops up whenever I come up to speed. I want to replace it with a metal one that's better quality but I just haven't got around to doing it yet. If you find a good mount, please let me know.
Thought I would check the last couple things that I hadn’t used on the boat yet. My running lights worked fine but my ski tow post will not screw in. Dealer solution was to mail me another post, it did not fit. I believe after some checking it is an alignment problem between the sleeve and the threads and will loosen the screws on the top plate and see what happens. Waiting on the proper square drive tool bit to arrive. Strange that you can’t get your post but I now have two!
 

Sie805

Member
Joined
Sep 21, 2020
Messages
18
Reaction score
5
Location
Northern CA
Thought I would check the last couple things that I hadn’t used on the boat yet. My running lights worked fine but my ski tow post will not screw in. Dealer solution was to mail me another post, it did not fit. I believe after some checking it is an alignment problem between the sleeve and the threads and will loosen the screws on the top plate and see what happens. Waiting on the proper square drive tool bit to arrive. Strange that you can’t get your post but I now have two!
I got a call the other day and allegedly my parts have arrived. We'll see come next week when I take it in.
 

Targa V19

Member
Joined
Mar 28, 2021
Messages
8
Reaction score
1
Location
Indiana
I got a call the other day and allegedly my parts have arrived. We'll see come next week when I take it in.
Make sure the ski pole fits! Got the proper tool, loosened the bolts, stuck the pole in and wiggled it around, screwed right in. Shouldn’t this have been checked by quality control? Still fits after torquing the bolts back up! Who do I charge tool cost and labor to? Oh well
 

Latest posts

Top